Data Processing and Event Streaming Delays
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted Dec 09, 2023 - 21:49 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 09, 2023 - 20:14 PST
Monitoring
From 6:45 PM on Dec 9th, 2023, most of our services are performing in a degraded state. This includes, but is not limited to, up to 80 minutes of data processing and event streaming lag and slower than usual chart performance. This is due to an AWS DynamoDB outage reported by AWS.

We expect no data loss during this incident, and no further actions are required by our customers.

We are monitoring the health of AWS DynamoDB. The next update will no later than 10PM.
Posted Dec 09, 2023 - 20:13 PST
This incident affected: Data (Data Processing, Event Streaming).