High latency on ingestion endpoints
Incident Report for Amplitude
Resolved
From Sept 15th 2023, 12:01 PM until 3:22 PM PT our ingestion endpoints, /http and /batch, are having high latency with more than usual SSL connection errors. As a result, a portion of incoming data might not be available in the charts or any downstream system. The incident is resolved. Since Amplitude might not have received some data (any data API call that we did not return a HTTP/200 success result), we cannot guarantee that there was no data loss. If there is any drop in your data, please consider resending the events to Amplitude.
Posted Sep 15, 2023 - 17:05 PDT
Monitoring
As of 15:22 PM PT, we have identified a probable root cause and we have applied a fix. We are now monitoring the system.
Posted Sep 15, 2023 - 15:47 PDT
Investigating
On Sept 15th 2023, 12:01 PM PT our ingestion endpoints, /http and /batch, are having high latency with more than usual SSL connection errors. As a result, a portion of incoming data might not be available in the charts or any downstream system. We are working on finding the root cause. All customers may have been impacted and as a result, it is recommended to perform a data connection retry. If possible, keep a copy of your data to send it after the incident is resolved.
Posted Sep 15, 2023 - 14:50 PDT
This incident affected: Data (Data Reception).